www.MegaSquirt.de

Das deutschsprachige MegaSquirt-Forum

VW 16V Sauger, Kaltlauf i.O., danach überfetten? Finde den Fehler nicht

Für alle Anfängerfragen die so auftauchen und irgendwie auch immer wieder auftauchen. Bitte vorher trotzdem die Suche benutzen!
Forumsregeln
Bitte vorher trotzdem die Suche benutzen!
Nachricht
Autor
christian_scirocco2
Beiträge: 28
Registriert: Mo Sep 11, 2017 8:28 pm

VW 16V Sauger, Kaltlauf i.O., danach überfetten? Finde den Fehler nicht

#1 Beitragvon christian_scirocco2 » Sa Jul 10, 2021 6:13 pm

Hallo,

ich bin schon einige ganze Zeit dabei meine MS3 aufzubauen. Das Projekt zieht sich schon über mehrere Jahre, nun ist es fast fertig, ich bekomme den Motor aber nicht richtig ans drehen und finde den Fehler nicht.
Grunddaten:
VW 1.8l 16V Sauger, mit sehr mildem Tuning(Nockenwellen, Kanäle)
verbaut sind:
MS3
315ccm Bosch Düsen, Benzindruck 3Bar (einstellbar)
Zündspule Passat (Wasted Spark)
Triggerrad vom Audi (60+2)
Leerlaufregelventil vom Corrado (2Pin PWM)
Drosselklappe (ohne Leerlaufschraube) mit Poti vom Audi 80? (jedenfalls alte Version)
Breitbandlambda Bosch LSU4.9 mit Spartan OEM Controller

Signale sind soweit i.O. Triggersignal, Zündfunken, Leerlaufventil, Drosselklappe - Lambda konnte ich nicht testen, bzw.zeigt immer 19,9 AFR an.

Software habe ich Tunerstudio (registriert, also mit Autotune). Ich habe meine vorher auf dem Prüfstand gemessenen Leistungsdaten(noch mit der Jetronic) zu dem Motor angegeben und dann die VE Tabelle errechnen lassen. Die Zündkennfeld habe ich auf dem VW Selbststudienprogramm übernommen. Damit habe ich dann den Motor gestartet:
16V Sauger.msq
(273.18 KiB) 16-mal heruntergeladen


Kaltstart ist wunderbar, springt an, braucht einen Moment bis er sich einpendelt und läuft ruhig. Nach ca. einer Minute beginnt er dann zu stottern und spotzeln, als wenn er im Sprit ersäuft. Ich habe versucht das ganze per Autotune (mit automatischen Update) zu korregieren, hat nicht geholfen.
Dann habe ich händisch versucht den Leerlauf zu korregieren, daß er da erstmal drin läuft. Also eigene IDLE Tabelle eingeschaltet und dann die Werte verstellt. Aber egal ob viel Sprit oder wenig, aggressivere Regelung und lahm, sobald der Motor auch nur den Hauch warm ist. Spotzelt er bei 400 U/Min und geht dann aus. Warmlaufanreicherung hatte ich auhc mal komplett auf 0 gesetzt, meine dann war es etwas besser.
Das einzige was überhaupt eine kleine veränderung gebracht hat - Motor ließ sich mit Gaspedal am Leben halten - war als ich nochmal die VE Tabelle generiert habe, dann aber als Leistungsdaten 70PS und 70lft.

Vielleicht habe ich einen gurndlegenden Denkfehler darin, wäre dankbar wenn jemand sich das Projekt mal ansehen würde.

Viele Grüße Christian

Benutzeravatar
Lukas412
Beiträge: 117
Registriert: Do Jun 04, 2009 7:28 pm
Wohnort: Wiesbaden
Kontaktdaten:

Re: VW 16V Sauger, Kaltlauf i.O., danach überfetten? Finde den Fehler nicht

#2 Beitragvon Lukas412 » So Jul 11, 2021 8:34 pm

Hallo Christian,

kannst du das mal mit Loggen und hier einstellen? Das würde bestimmt weiter helfen.

Soweit ich weiß, melden Breitband Lambdasonden mager wenn sie "Nass" werden also wenn der Motor zu Fett läuft. Teufelskreis vor allem bei Auto-Tune.
Wenn der Motor zu Mager läuft kann das Gemisch nicht verbrennen und macht die Sonde evtl auch Nass.
Hatte bei schon das Problem das er die Custom Werte für die Lambdasonde vergessen hat und falsch angezeigt hat.

Gruß
Lars
Corrado ABF 16V G60

Teile Verkauf!

christian_scirocco2
Beiträge: 28
Registriert: Mo Sep 11, 2017 8:28 pm

Re: VW 16V Sauger, Kaltlauf i.O., danach überfetten? Finde den Fehler nicht

#3 Beitragvon christian_scirocco2 » Do Jul 15, 2021 2:03 pm

Hallo Lars,

versuche mich mal am Datenlogger, bislang noch nicht benutzt.
Habe in englischsprachigen Foren noch gelesen und ein paar kleinere Fehler gefunden, wo ich Einstellungen falsch verstanden habe. Einfluß der Lambdasonde auf die regelung habe ich erstmal deaktiviert.
Mittlerweile springt er gut an, das spotzeln ist weg, nimmt auch im Stand Gas an, anfahren ein paar Meter vor/zurück gingen, mehr habe ich noch nicht getestet.
Wenn ich das Leerlauf Regelventil händisch auf 24% setze habe ich einen ruhigen Leerlauf.
Auf Auto ist die Standgasregelung noch sehr bescheiden, da muß ich noch am Regler nachbessern.

Danke für den Tip mit der nassen Sonde, daß könnte dann der Grund sein, warum er noch nichts anzeigt. Ich seh dann mal zu das ich die Tage mit dem Wagen eine Runde um den Block drehe (Verkabelung erst noch ordentlich befestigen) - dann mal sehen ob die Sonde was anzeigt. Bei einem Test mit der alten Einspritzung gab der Lambdacontroller sein Schmalband und Breitband Signal aus, Die Megasquirt erkennt auf dem Eingang ebenfalls das 0-5V Signal (mit Poti/Spannungsteiler getestet).

Ich melde mich dann wieder.

Gruß Christian

christian_scirocco2
Beiträge: 28
Registriert: Mo Sep 11, 2017 8:28 pm

Re: VW 16V Sauger, Kaltlauf i.O., danach überfetten? Finde den Fehler nicht

#4 Beitragvon christian_scirocco2 » Fr Jul 16, 2021 8:03 am

So, Fehler an der Sonde gefunden. Habe bei einem Stecker(Klopfsensor) der doppelt Masse bekommt vergessen die Brücke zu machen, so bekam nur die Lambdaheizung Masse, nicht aber "electronic ground". Nun wird mir der AFR Wert angezeigt, bin auch schon ein paar Meter gefahren mit Autotune bei dem die Software schon fleissig am nachregeln ist.
Leerlauf sägt er noch, reagiert nur leicht auf ändern der Reglerparameter (schwankt zwischen 800-1200U/Min). Denke mal daß dürfte softwaremäßig in den Griff zu bekommen sein, muß mich mehr über PID einlesen.
Mit dem Datenlogger habe ich mich noch nicht beschäftigt, war froh gestern den Fehler gefunden zu haben und eine kurze Runde um den Block drehen zu können. :D

_Tom_
Beiträge: 315
Registriert: Mo Aug 27, 2007 1:09 am

Re: VW 16V Sauger, Kaltlauf i.O., danach überfetten? Finde den Fehler nicht

#5 Beitragvon _Tom_ » Sa Jul 17, 2021 6:47 pm

Moin,
die Leerlaufregelung erst anfassen wenn der Motor gut läuft. Sprich dein VE Table passt, deine Zündung ebenfalls gut ist usw. Einen schlecht laufenden Motor regeln wird nix.
Gruß und viel Erfolg
A3 1.8t Allrad mitten im Umbau.

christian_scirocco2
Beiträge: 28
Registriert: Mo Sep 11, 2017 8:28 pm

Re: VW 16V Sauger, Kaltlauf i.O., danach überfetten? Finde den Fehler nicht

#6 Beitragvon christian_scirocco2 » Di Jul 20, 2021 3:02 pm

Ok,

was meinst du wieviele Kilometer müssen so etwas zusammen kommen bis man mit der Autotune Map etwas anfangen kann? Nach einer kurzen Fahrt von 5km - Standgas war katastrophal bei richtig warmen Motor - haben die Werte sich schon ziemlich nach unten korregiert, meist so um 8-10 Punkte, z.B. von 93 auf 86 usw..
Den Datenlogger habe ich entdeckt, der scheint in der normalen registrierten Version von Tunerstudio nur ein paar Sekunden aufnehmen zu können. :?: :!:

christian_scirocco2
Beiträge: 28
Registriert: Mo Sep 11, 2017 8:28 pm

Re: VW 16V Sauger, Kaltlauf i.O., danach überfetten? Finde den Fehler nicht

#7 Beitragvon christian_scirocco2 » Mi Jul 21, 2021 5:32 pm

Hast du vielleicht noch einen Tip wie ich den Leerlauf denn händisch erstmal einigermaßen hin bekomme, so daß ich wenigstens einigermaßen fahren kann?
Jetzt gerade bleibt das Idle valve bei so 25-26% recht ruhig stehen, Drehzahl geht aber derzeit hoch(1400) und runter(400-500).
Ich kapiere das gerade nicht, daß macht er also, weil er je nach Lastbereich/Drehzahl andere Einspritzwerte/Zündwinkel hat?

Das Bescheidene ist halt, bevor ich irgednwo in einen Straßenbereich komme wo ich den Wagen ruhig fahren kann, muß ich bestimmt 10mal anhalten/losfahren. Ampeln, viel rechts vor links, beruhigte Zone...

Ventil auf Openloop statt clopes loop stellen?

ibizafreak
Beiträge: 75
Alter: 34
Registriert: So Nov 13, 2016 5:14 pm

Re: VW 16V Sauger, Kaltlauf i.O., danach überfetten? Finde den Fehler nicht

#8 Beitragvon ibizafreak » Mi Jul 21, 2021 5:47 pm

Nagel dein Idle Valve fest. So wie du schon gesagt hast auf Open Loop stellen.

Dann im unteren Drehzahlbereich dein VE Table gleich stellen. Also alles zwischen 0 - 1100 und MAP 0 - 100kpa den gleichen Wert einfach rein schreiben. Am besten ca lambda 0,9.

Dann stell dir den Idle Advance ein. Bau dir ne Rampe. Bei niedriegen Drehzahlen hoher Zündwinkel bei hohen drehzahlen eben etwas weniger Zündwinkel.

Musst du nen bisschen mir probieren und dein Ventil und Zündwinkel etwas aufeinander abstimmen.

Ich fahre schon immer ohne Leerlaufregelventil. Einfach feste Position der Drosselklappe. Läuft bei mir auch super.

Grüße

Philipp
Seat Ibiza Cupra 2 - Allradumbau
2.0l 16V Turbo (ABF)
2017-2020: GTX30/76
2020- : Precision PT6466 Gen2
NG-Motorsport Zylinderkopf
02Q 6-Gang Getriebe aus S3 8P
KDFI 1.4 PnP - MS2/Extra 3.4.2

christian_scirocco2
Beiträge: 28
Registriert: Mo Sep 11, 2017 8:28 pm

Re: VW 16V Sauger, Kaltlauf i.O., danach überfetten? Finde den Fehler nicht

#9 Beitragvon christian_scirocco2 » Do Jul 22, 2021 9:22 am

Hallo Ibiza Freak,

danke, daß mache ich und melde mich wieder.

Nur zur Verständnis, das Idle Advance ist dann eine Verschiebung des Zündzeitpunkts wenn sich die Drosselklappe in Idle Position befindet?
Also wenn z.B. in der normalen IginitionTabelle der Zündwinkel bei 1200 U/Min auf (-)10Grad steht und in der Idle Advance Tabelle (+)3Grad eingetragen ist, habe ich danach effektiv 7 Grad?!

Viele Grüße Christian

ibizafreak
Beiträge: 75
Alter: 34
Registriert: So Nov 13, 2016 5:14 pm

Re: VW 16V Sauger, Kaltlauf i.O., danach überfetten? Finde den Fehler nicht

#10 Beitragvon ibizafreak » Do Jul 22, 2021 9:48 am

Jein. :D

Ich glaub man kann beides einstellen.
Einmal Addition und einmal Total.

Ich hab Total eingestellt. Sprich wenn er Idle erkennt dann nimmt er den Zündwinkel aus deiner Kurve und nicht mehr aus dem Kennfeld.
Seat Ibiza Cupra 2 - Allradumbau
2.0l 16V Turbo (ABF)
2017-2020: GTX30/76
2020- : Precision PT6466 Gen2
NG-Motorsport Zylinderkopf
02Q 6-Gang Getriebe aus S3 8P
KDFI 1.4 PnP - MS2/Extra 3.4.2

christian_scirocco2
Beiträge: 28
Registriert: Mo Sep 11, 2017 8:28 pm

Re: VW 16V Sauger, Kaltlauf i.O., danach überfetten? Finde den Fehler nicht

#11 Beitragvon christian_scirocco2 » Do Jul 22, 2021 11:59 am

Gut zu wissen! Werde dann auch Total nehmen und je nachdem was besser läuft 6 oder 8 Grad vor OT (Standartwerte des 16V)

christian_scirocco2
Beiträge: 28
Registriert: Mo Sep 11, 2017 8:28 pm

Re: VW 16V Sauger, Kaltlauf i.O., danach überfetten? Finde den Fehler nicht

#12 Beitragvon christian_scirocco2 » Sa Jul 24, 2021 5:09 pm

Hallo,

irgendwie klappt es nun gar nicht mehr. Kann aber nicht wirklich den Fehler finden, also Hardwaretechnisch scheint alles zu funktionieren, viele der Teile sind noch neu oder so gut wie. Habe mal drei Loggings gemacht, vielleicht sieht einer von euch was da raus.
Die Drehzahl schwankt so stark, daß der Motor nur ganz kurz IDLE anzeigt, und sonst Acceleration. bzw Decceleration.
Aks zip Datei zusammengeafsst, die .mlg Dateien können nicht direkt angefügt werden?!
DataLogs.zip
(78.58 KiB) 2-mal heruntergeladen

christian_scirocco2
Beiträge: 28
Registriert: Mo Sep 11, 2017 8:28 pm

Re: VW 16V Sauger, Kaltlauf i.O., danach überfetten? Finde den Fehler nicht

#13 Beitragvon christian_scirocco2 » So Jul 25, 2021 11:49 pm

So, ein Update.
Habe nun dies gemacht:
Kennfeld von VE und Ignition deutlich grober gestaltet, 20-100KPa in 10er Schritten, Drehzal im unteren Bereich 500,1000,1500,1750,2000...
Den Unterdruckanschluss für das Steuergerät an den Kanal des BKV angeschlissen wo auch das Original Steuergerät angeschlossen ist um Druckschwankungen zu vermeiden - Bekannter hat noch empfohlen einen Mopedbenzinfilter mit indie Leitung zu setzen der nochmal Schwankungen raus nimmt. Den muß ich erst noch besorgen.

So war heute fahren und auch Leerlauf im openloop möglich, das Autotune war ebenfalls fleissig am korregieren.
Leerlauf teils nur +-40U/Min am schwanken, teils +-300.
Ruckeln beim sanften Beschleunigen und Schubbetrieb mit geringer Last.

Nun bin ich am überlegen welchen Punkt ich als nächstes Ansetzen soll?
-Schubabschaltung aktiveren?
-Beschleunigungsanreicherung optimieren?
-Leerlauf ? Dabei bin ich mir gerade nicht sicher, vermute daß da trotz openloop außer dem festen PWM Signal des Leerlaufventil noch ein Wert einspielt der Temperaturabhängig die Einspritzmenge beeinflusst, nur wo?

Wolfman11
Beiträge: 45
Registriert: Do Jul 10, 2014 5:08 am
Wohnort: bei Hamburg Nord-Osten

Re: VW 16V Sauger, Kaltlauf i.O., danach überfetten? Finde den Fehler nicht

#14 Beitragvon Wolfman11 » Di Jul 27, 2021 3:18 am

Hi,
Du machst kannst Dir die Leerlaufsache unnötig schwer. Sicherlich hat Deine Drosselklappe einen Anschlag, oft eine ganz kleine, verklebte Schraube. Von der das Werkstatthandbuch sagt "auf keinen Fall verstellen". Ist für Dich natürlich Quatsch. Wenn die so eingestellt ist, das er bei warmem Motor bereits mit der gewünschten Drehzahl läuft, nur -50 Umdrehungen, bekommt das Regelventil den Rest viel leichter hin. Es muss dann nur ganz leicht öffnen, um auf die Zieldrahzahl zu kommen und jedes "sägen" auf 400 Umdrehungen und Ausgehen ist sowieso erledigt. Wozu willst Du denn unter die untersten Drehzahl regeln können? Ist doch Unfug. Wenn Du dann erst mal alle Regelungen ab stellst, kannst Du ganz leicht die richtige Einspritzdauer für den Leerlauf finden. Irgendwo um Lambda 1 wird er dann ganz ruhig laufen. Einen exakten Lambdawert kann man nicht vorhersagen, weil ein Teil des Sprits immer erst im Auspuff verbrennt. Je nach Brennraumform mehr oder weniger. Schlechte Turbulenz im Brennraum braucht eben mehr Sprit als gute. Darum läuft ein Motor bei 1.1 noch rund und andere erst bei 0.95, etwas übertrieben gesagt. Der theoretisch ideale Lamdawert ist genau das: Theorie.
Wenn man dann erst mal ein paar sauberer Punkte in seinem Tune hat, wird der Rest viel simpler.
Daher würde ich Dir raten bei langsam, schrittweise gesteigerter Drehzahl, erst mal ein Null Last Kennfeld zu schreiben. So das Du den Motor sauber im Stand hoch drehen kannst und er bei jeder Drehzahl sauber läuft. Natürlich ohne Beschleunigungsanreicherung und Lambdaregelung.
Oft wird vergessen das Leerlauf- und Lambda-Regelungen nur Abweichungen vom Ideal korrigieren sollen, nicht selber bestimmen was gemacht wird. Sonst könnten wir ja die ganzen Kennfelder vergessen und komplett auf den Regelungen laufen. So wie eine Klopfregelung auch kein sauber abgestimmtes Zündkennfeld ersetzt, sondern nur eine Notbremse ist, wenn etwas schief geht.
Vielleicht solltest du da mal drüber nach- und dann etwas umdenken, bei all den Autotune Funktionen. Die ersetzen keinen gesunden Technikerverstand. Leider.
Du mutest den Funktionen etwas zu viel zu! Die sind für die Fein, aber nicht für die Erstabstimmung.

Benutzeravatar
Carsten
Beiträge: 720
Registriert: Fr Jan 06, 2006 6:07 pm
Wohnort: Donnersberg (6730x)

Re: VW 16V Sauger, Kaltlauf i.O., danach überfetten? Finde den Fehler nicht

#15 Beitragvon Carsten » Di Jul 27, 2021 8:26 am

Moin...

genau richtig!

Das Mapping ist ein Prozess der schrittweisen Verfeinerung und hier ist immer wieder zu lesen, dass die Helferlein wie Autotune erst richtig sinnvoll genutzt werden können, wenn das Gerüst steht.

Ein stabiler Leerlauf ist ohne jegliche algorithmische Hilfe möglich. Und allein mit Idle Advance (mehr Frühzündung bei fallendem Leerlauf) bekommt man das schon richtig gut hin, ohne Regelventil...

Ich gehe an die mapperei immer mit dem Ansatz: "erstmal die einfache mechanische Welt nachbilden, also Zündzeitpunkt linear über Drehzahl steigern wie ein Fliehkraftversteller, Kennfeld für Einspritzung wie ein primitiver Vergaser ohne Beschleuniger-Pumpe.
Damit muss das Auto statischen Zuständen (konstante Drehzahl, konstante Last, konstante Gaspedal-Stellung erst mal fahren. Und danach wird dran gearbeitet, dass die Übergänge zwischen diesen statischen Bedingungen schön werden ...

Just my 2 Cent....

Carsten


Zurück zu „Anfänger helfen Anfängern“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste