www.MegaSquirt.de

Das deutschsprachige MegaSquirt-Forum

Wandernder Zündwinkel trotz fixed Advance

Hier könnt ihr MegaTune downloaden
Nachricht
Autor
OezyB
Beiträge: 542
Registriert: Di Nov 16, 2010 5:13 pm

Wandernder Zündwinkel trotz fixed Advance

#1 Beitragvon OezyB » So Jun 17, 2018 4:47 pm

Moin moin zusammen,

an einem aktuellem Projekt habe ich zur Abwechslung zu einer KDFI PnP gegriffen. Motor ist ein BMW 2,5l m50 mit standard 60-2 Triggerwheel und VR Sensor. Der Motor läuft mit COP auf wasted spark (passive spulen, keine Treiber).

Drehzahlsignal und alle sonstigen SIgnale sind sauber. Jetzt ist mir beim Abblitzen aufgefallen, dass beim der Zündwinkel mit der Drehzahl wandert, obwohl der ZZP auf fix gestellt ist. Im Spark summary steht ist auch zu sehen, dass keine korrektur eingreift. Hab zur Sicherheit auch im Sparktable mal alles auf 0 gestellt.
Was ich bisher probiert habe:
-Spark Hardware latency 0 bis 499 alles durchprobiert
-Plarität vom VR Sensor getauscht, dabei Rising/Falling edge getauscht, triggerlogger dabei natürlich gecheckt
-VR Sensor getauscht
-Zündspule getauscht
-Dwell time erhöht/verrringert
-tooth prediction oder wie das heisst aus gestellt
-ansteuerung der Zündspulen geprüft (invertiert oder nicht weiss nicht mehr, aber richtig rum :))
-nicht nur auf 0° abgeblitzt, sondern auch mal 5° und 10°
-Firmware nochmal drauf gespielt: Hierbei war das Problem kurzzeitig weg, aber kam dann allmählich wieder

Die hardware latency funktion ist ja eigentlich nur dafür da, wenn der Zündwinkel mit der Drehzahl richtung spät wandert. Hier ist es aber anderserum, der Zündfunke wandrt richtung früh, was für mich einfach keinen Sinn ergibt. Es fahren so viele KDFI m50 PnP rum, das kann nicht sein, dass ich der einzige mit dem Problem bin. Ich habe das Gefühl, dass einfach viele unbemerkt mit dem Problem rumfahren.

Hat jemand eine Idee was da schief gelaufen sein könnte? geloggt habe ich das jetzt nicht, aber die MSQ hänge ich mal ran.


Ich hab mal bisschen gegoogelt und das gefunden:

http://www.efi101.com/forum/viewtopic.php?t=9090&sid=4824bc0a52b2c1eded3a75c2ea965b4b
Interessant ist der Beitrag von MJR.

Er sagt etwas von zu viel Trigger angle. Der Trigger angle ist bei der KDFI auf 324° voreingestellt. Mich irritert dabei, dass ich beim 6 zylnder normalerweise Trigger Angle im Bereich von 60 bis 90 habe. Wobei das Abblitzen auf 0° mit dem Trigger angle schon passt..Wenn man sich das hier aber mal anguckt, dann ist es klar, warum quasi eine Umdrehung früher der Trigger Angle anfangenn muss zu zählen.
http://www.msextra.com/forums/viewtopic.php?f=101&t=34345
Also sollte das mit den 324° schon passen.
Dateianhänge
2018-06-17_16.45.42.msq
(119.11 KiB) 20-mal heruntergeladen
(OO==[][]==OO)
e30 335i m30 turbo
Holset HX55, ENEM 300° M7 Nockenwelle, Sequenziell,
MS3x | launch control | boost control | Traction Control | CAN EGT

Benutzeravatar
franksidebike
Beiträge: 3500
Registriert: So Apr 03, 2005 6:28 pm
Wohnort: http://de.wikipedia.org/wiki/Wathlingen

Re: Wandernder Zündwinkel trotz fixed Advance

#2 Beitragvon franksidebike » So Jun 17, 2018 8:16 pm

Hallo Oezy
OezyB hat geschrieben:-Plarität vom VR Sensor getauscht, dabei Rising/Falling edge getauscht, triggerlogger dabei natürlich gecheckt
-ansteuerung der Zündspulen geprüft (invertiert oder nicht weiss nicht mehr, aber richtig rum :))

die zwei sachen könnten es doch nur sein!
wobei ich auf falsche Ansteuerung der spule tippen würde.

wenn du im TS Rising/Falling Edge oder invertiert oder normal wechselst/änderst, bitte immer die MS stromlos/reset machen damit die das auch wirklich mit bekommt!
Gruß Frank

OezyB
Beiträge: 542
Registriert: Di Nov 16, 2010 5:13 pm

Re: Wandernder Zündwinkel trotz fixed Advance

#3 Beitragvon OezyB » So Jun 17, 2018 9:51 pm

Also das mit der Ansteuerung der Spulen prüfe ich nochmal, aber bei Zündung an darf die mosfetleitung an der Spule kein masseschluss haben, und so hab ich es eingestellt. Also 12v gemessen vom batterieplus zu signal Leitung zündspule und wenn das Multimeter 12v anzeigt, ist der mosfet geschaltet und würde sozusagen die Spule laden. Hab dann das so eingestellt, dass keine 12v angezeigt werden. So hab ich das geprüft.

Ich hab immer nach jeder Einstellung natürlich das Steuergerät rebootet.

Ich tippe aktuell eher Richtung triggerscheibe... Hatte eine vom nonvanos und eine vom vanos zur Verfügung, vielleicht hab ich da die falsche genommen..
(OO==[][]==OO)
e30 335i m30 turbo
Holset HX55, ENEM 300° M7 Nockenwelle, Sequenziell,
MS3x | launch control | boost control | Traction Control | CAN EGT

Benutzeravatar
franksidebike
Beiträge: 3500
Registriert: So Apr 03, 2005 6:28 pm
Wohnort: http://de.wikipedia.org/wiki/Wathlingen

Re: Wandernder Zündwinkel trotz fixed Advance

#4 Beitragvon franksidebike » Mo Jun 18, 2018 8:11 am

Morgen
OezyB hat geschrieben:Ich tippe aktuell eher Richtung triggerscheibe... Hatte eine vom nonvanos und eine vom vanos zur Verfügung, vielleicht hab ich da die falsche genommen..

was kann den an der Triggerscheibe falsch sein? material= Signal nicht sauber= synclost! lose auf der KW=zzp springt vor/rück!
Frank

OezyB
Beiträge: 542
Registriert: Di Nov 16, 2010 5:13 pm

Re: Wandernder Zündwinkel trotz fixed Advance

#5 Beitragvon OezyB » Mo Jun 18, 2018 11:09 am

Das triggersignal ist ja auch sauber. Ich hab mal bisschen nach den unterschieden der Triggerscheiben gegoogelt. Hier sind die unterschiede ganz gut zu sehen:

[url][/http://m54megasquirt3.blogspot.com/2011/09/timing-settings.htmlurl]

Wenn ich die Triggerscheibe vom nonvanos eingebaut hätte, würde der Trigger Offset ja bei ca 84 liegen und würde demnach mit den eingestellten 324 gar nicht laufen. Daran kann es also nicht liegen.

Eine weitere Vermutung ist es, dass die MS irgendwie ein Problem hat, eine ganze Umdrehung lang zu zählen, und da irgendwie ein Fehler auftritt, aber ob so ein mikrocontroller sich verzählen kann ? Eher nicht. Zumal es bei zich anderen Leuten funktioniert.

Durch die Blitzpistole kann sowas nicht entstehen, oder? das bezweifle ich, da der Zündwinkel ja Richtung früh geht. Die kann ja nicht blitzen, bevor der Funke gestartet wird.

Das einzige, das da noch bleibt, ist: die Zündspulen feuern früher ab, als sie sollen. Kann passieren bei Spulen mit internen Treibern und zu langer dwell, aber das hier sind passive spulen. Vielleicht steuere ich die Spulen ja doch falsch an? werde es nachher mal prüfen. Oder die Spannungskorrektur erhöht mir die DWELL, prüfe ich nachher auch mal.
(OO==[][]==OO)
e30 335i m30 turbo
Holset HX55, ENEM 300° M7 Nockenwelle, Sequenziell,
MS3x | launch control | boost control | Traction Control | CAN EGT

ToppeR
Beiträge: 39
Alter: 36
Registriert: Di Mai 06, 2008 10:11 am

Re: Wandernder Zündwinkel trotz fixed Advance

#6 Beitragvon ToppeR » Mo Jun 18, 2018 12:22 pm

bin in den megasquirt Thema nicht ganz drin, aber ich würde die Triggerscheibe wechseln und mit den 84° Offset probieren. Bei anderen Steuergeräten kann man auch den Trigger Touth angeben und damit wird das Offset kleiner.

OezyB
Beiträge: 542
Registriert: Di Nov 16, 2010 5:13 pm

Re: Wandernder Zündwinkel trotz fixed Advance

#7 Beitragvon OezyB » Mo Jun 18, 2018 2:11 pm

@Topper
ja das wäre ein Ansatz. Wäre aber schade, weil der kurbeltrieb zusammen gewuchtet wurde, aber ist nicht weiter schlimm.. Jetzt verstehe ich auch, warum bei der EMU erstmal der Zahn und dann der Winkel eingegeben wird :D

Aber da muss ein anderes Problem vorliegen, bei so vielen M50 M50 usw Motoren klappt das und nur bei dem hier nicht? Kann ich nicht glauben. Aber wenn ich nichts finde, muss ich ja weiter suchen.. Dann halt try and error :D
(OO==[][]==OO)
e30 335i m30 turbo
Holset HX55, ENEM 300° M7 Nockenwelle, Sequenziell,
MS3x | launch control | boost control | Traction Control | CAN EGT

OezyB
Beiträge: 542
Registriert: Di Nov 16, 2010 5:13 pm

Re: Wandernder Zündwinkel trotz fixed Advance

#8 Beitragvon OezyB » Mi Jun 20, 2018 11:14 am

soo Problem gelöst. Um diesen Thread mal abzuschliessen, schreibe ich nochmal rein was das Problem war :D

Da der M50 eine Coil on Plug Zündung fährt, habe ich die Blitzpistole an die Signalleitung geklemmt. Dadurch blitzt die Lampe aber schon, wenn die DWELL time anfängt, also immer so ca 2-3ms bevor der Zündfunke anfängt. Das klingt nicht viel, aber wenn man mal überlegt, dass bei 1000RPM eine ganze Umdrehung 60ms dauert, sind 3ms immerhin 5%. Bei 2000RPM sind es 30ms pro Umdrehung, also 10% und bei 3000rpm schon 20%. So kam das Wandern vom Funken zustande.

Also hab ich ein Zündkabel an die Zündspule gemacht und darauf abgeblitzt und alles läuft :)

Gruß
Özkan
(OO==[][]==OO)
e30 335i m30 turbo
Holset HX55, ENEM 300° M7 Nockenwelle, Sequenziell,
MS3x | launch control | boost control | Traction Control | CAN EGT

Benutzeravatar
Dominik335i
Beiträge: 834
Registriert: Di Mai 17, 2011 6:11 pm

Re: Wandernder Zündwinkel trotz fixed Advance

#9 Beitragvon Dominik335i » Mi Jun 20, 2018 2:27 pm

Sehr interessant. Und gut zu wissen, dass ich es bisher immer - durch Glück - richtig gemacht habe... :mrgreen:
Caterham R400 Superlight powered by Rover 1,8l K Series NA
"SixFour" MS2 vollsequentiell
232 PS vs. 490 kg --> "Simplify, then add lightness” (Colin Chapman)

OezyB
Beiträge: 542
Registriert: Di Nov 16, 2010 5:13 pm

Re: Wandernder Zündwinkel trotz fixed Advance

#10 Beitragvon OezyB » Do Jun 21, 2018 1:19 pm

jetzt hat sich das bei mir auch eingebrannt hahaa :D
(OO==[][]==OO)
e30 335i m30 turbo
Holset HX55, ENEM 300° M7 Nockenwelle, Sequenziell,
MS3x | launch control | boost control | Traction Control | CAN EGT


Zurück zu „Tuning“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste