www.MegaSquirt.de

Das deutschsprachige MegaSquirt-Forum

TÜV AU Idle

Nachricht
Autor
Timbo
Beiträge: 3
Registriert: Mo Apr 30, 2018 12:17 pm

TÜV AU Idle

#1 Beitragvon Timbo » Mo Apr 30, 2018 12:32 pm

Mahlzeit zusammen!

Jeder von euch kennt doch bestimmt die Angst wenn es zum TÜV geht mit einer selbstgebauten Map und der Abgastest ansteht...
Nun, meiner hat jetzt leider die AU nicht bestanden, weil Leerlaufdrehzahl und Lamdawert nicht passten.

Problem ist folgendes:

Wenn ich die Drehzahl über "idle PWM Dutycyle" anpasse läuft er zu fett, wenn ich dann in der Fuelmap im entsprechenden Bereich runterregele geht er mir aus.
Wenn ich zuerst die Fuelmap ändere und dann die Drehzahl anpasse geht er mir ebenso aus und lässt sich nur wieder starten wenn ich ordentlich anfette... :cry:

Belasse ich es dann aber bei dem "ein bisschen zu fett" und drehe ein paarmal hoch und lasse die Drehzahl wieder runterfallen, geht er entweder aus oder pendelt sich auf ca 700 rpm ein (eingestellt waren 900!).. also muss ich da wieder am idle pwm dutycycle nachregeln dass es passt.
Wenn ich aber dann den Motor ausmache und erneut starten will ist die Drehzahl wieder viel zu hoch?! :shock:

Zudem "pulsiert" die Drehzahl in unregelmäßigen Abstanden, wie als wenn sich ein Verbraucher an und wieder abschalten würde... Der lüfter ist es aber nicht, den habe ich jetzt mal dauerhaft aktiviert, und auch sonst schalte ich nichts zu bzw ab..

So die AU zu bestehen ist natürlich absolutes Russisch Roulette mit einem voll geladenen Revolver, deswegen meine Hoffnung dass hier jemand vll schon einmal ein ähnliches Problem hatte oder einen Lösungsansatz hat.

Lg

Timbo
Beiträge: 3
Registriert: Mo Apr 30, 2018 12:17 pm

Re: TÜV AU Idle

#2 Beitragvon Timbo » Mo Apr 30, 2018 12:37 pm

Als Ergänzung dazu:
Fahrzeug ist ein Mx5 NA mit Turboaufladung,
Rx8 Einspritzdüsen
VAG Cop's mit Iridium Kerzen

Ich habe mich gestern ein bisschen an den Injector Deadtimes versucht, da es ja leider iwie keine zuverlässigen Werte dazu gibt...
Das Pulsieren ist damit nur leidlich besser geworden, vll hat trotzdem ja jemand da Werte welche sauber funktionieren?

Benutzeravatar
squenz
Beiträge: 212
Registriert: Sa Dez 20, 2014 11:11 pm
Wohnort: München

Re: TÜV AU Idle

#3 Beitragvon squenz » Mo Apr 30, 2018 1:08 pm

Sowas aus der Ferne ohne Logs oder MSQ zu beurteilen ist so gut wie unmöglich. Bitte poste also zumindest mal deine aktuelle MSQ.
Ich war schon mehrfach zur AU und mache hierzu dann immer die closed loop lambda control (EGO Control) an. Der Leerlauf läuft bei mir dauerhaft im closed loop. Wenn beides klappt sollte man die AU - zumindest was die Steuerungsseite betrifft - ohne Probleme bestehen.

Hier mal ein paar Ansätze:

- Wenn die Drehzahl stark schwankt und der Motor ausgeht hast Du im entsprechenden Map Bereich evtl. zu große Sprünge zwischen den VE Werten. Versuche also die umliegenden Zellen etwas mehr anzugleichen damit das Gemisch im entsprechenden Bereich "stabiler" bleibt.
- Hat das o.g. geklappt ermittelst Du im open loop erst mal welche PWM für die gewünschte LL Drehzahl notwendig ist. Danach kann man auf closed loop umstellen und hierzu die ermittelten Werte mit etwas Aufschlag in das lookup table eintragen.

Die Dead Times zu den Injektoren kann man empirisch selbst ermitteln indem man mit den "Squirts per cycle" variiert. Die AFR Werte sollten konstant bleiben, auch wenn man die Anzahl der Einspritzvorgänge je Zyklus verdoppelt. Verändert sich der AFR Wert ist die Dead Time inkorrekt. Das ist im Augenblick aber nicht dein aktuelles Problem, denn diese Art die Totzeit zu ermitteln funktioniert auch erst wenn man einen stabilen Leerlauf hat.

Ich gehe mal stark davon aus dass dein MX-5 noch die Seriennocken hat, da sollte ein stabiler Leerlauf also gar kein Problem sein.

Viele Grüße

Markus
Toyota Starlet Daily - Microsquirt V3 mit MS2-Extra V3.4.2
Mazda RX-7 Turbo - Microtech LT-8s

Timbo
Beiträge: 3
Registriert: Mo Apr 30, 2018 12:17 pm

Re: TÜV AU Idle

#4 Beitragvon Timbo » Mo Apr 30, 2018 1:21 pm

Hey Markus,
erstmal danke für die ersten Tipps!
Werde heute Abend meine aktuelle MSQ mal reinstellen, vll findet ja irgendjemand was gravierendes...

Die umliegenden Zellen haben alle den selben Wert wie die, auf welchen die Drehzahl steht. Daran kann es nicht liegen, leider :(
Das mit dem PWM ermitteln kann ich mal veruchen, kannst du das ggf nochmal genauer ermitteln?

Und ja, ich fahre serien-nocken :D

kamphausen
Beiträge: 6
Registriert: Fr Okt 06, 2017 8:51 am

Re: TÜV AU Idle

#5 Beitragvon kamphausen » Mi Jun 06, 2018 7:59 pm

Denke mal, die RX-8 Düsen haben viel höhere Durchsätze? Das führt dann bei Leerlauf zu zu kleinen Einspritzzeiten...
Entweder, Du versuchst mal nen unterdruckgesteuerten Benzindruckregler, der bei Leerlauf den Druck senkt -> längere Öffnungszeiten
Oder Du arbeitest evtl. mit "Staged Injection" , wo der zweite Düsensatz erst bei z.B. 2500U/Min einsetzt?

Was würden denn die originalen Düsen an Durchsatz schaffen?

Peter

Jack-Lee
Beiträge: 575
Registriert: Mi Feb 01, 2017 12:46 pm

Re: TÜV AU Idle

#6 Beitragvon Jack-Lee » Do Jun 07, 2018 10:52 am

Servus,

wie sieht das Zündkennfeld aus? Konnte selbst bei einem Motor ohne Leerlaufregelung schlicht über die Zündung (Lambda war immer auf 1) einstellen.
Eingestellt wird das über "Idle RPM Advanced Timing". Letzter Button im Reiter Startup/Idle
Unterhalb der Leerlaufdrehzahl gebe ich einfach nennenswert mehr Vorzündung. Funktioniert super.

Bob 16V
Beiträge: 37
Registriert: Mi Jan 27, 2016 7:59 pm

Re: TÜV AU Idle

#7 Beitragvon Bob 16V » Do Jun 07, 2018 10:14 pm

Interessiert mich jetzt etwas genauer. Was heisst "nennenswert mehr". Wo sollten die Drehzahlschritte liegen. Wird der Wert zur Zündung addiert? Wieviel Grad höher ist realistisch?
Golf III 16V (ABF) Turbo
K-Data kdfi V1.4 PNP MS2 V3.4.2

Benutzeravatar
Alfagta
Beiträge: 2049
Alter: 97
Registriert: Mo Jan 24, 2011 2:24 pm
Kontaktdaten:

Re: TÜV AU Idle

#8 Beitragvon Alfagta » Do Jun 07, 2018 10:59 pm

Servus.

Wenn zu z.B.: im Idle 10° Zündung hast und bei 900Rpm bist setzt du bei 700 Rpm die Zündung auf 15° und bei 1100 auf 5° in der Idle Advance Table.
Wer aufhört besser zu werden hat aufgehört gut zu sein
Alfa 156 GTA
Alfa 75 Race Car MS III -- alway latest FW
Alfa 164 V6 Turbo
Test MS II --always latest FW
Tunerstudio V3.0.18 Registered
MLog View V4.1.12 Registered
MLog View HD V4.1.12 Registered

Bob 16V
Beiträge: 37
Registriert: Mi Jan 27, 2016 7:59 pm

Re: TÜV AU Idle

#9 Beitragvon Bob 16V » Fr Jun 08, 2018 7:20 am

D. h. bei IDLE aktiv werden die Einstellungen aus dem Advance Table genommen und nicht die aus dem normalen Zündkennfeld? Mit welcher Gauge kann ich das kontrollieren? Hab das Gefühl das macht die MS aber ich kann es nicht ablesen.
Golf III 16V (ABF) Turbo
K-Data kdfi V1.4 PNP MS2 V3.4.2

Jack-Lee
Beiträge: 575
Registriert: Mi Feb 01, 2017 12:46 pm

Re: TÜV AU Idle

#10 Beitragvon Jack-Lee » Fr Jun 08, 2018 8:08 am

Kann man einstellen ob die Werte in der Tabelle addiert werden sollen oder als Absolutwerte übernommen (Und ab wann diese überhaupt eingesetzt werden). Letzteres finde ich einfacher zu machen.
Und man kann das ablesen : Über den Zündwinkel.


Zurück zu „Generelle Informationen / Fragen“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast