www.MegaSquirt.de

Das deutschsprachige MegaSquirt-Forum

Käfer 2,7l Typ4

Nachricht
Autor
Benutzeravatar
porschekäfer
Beiträge: 288
Alter: 40
Registriert: Do Okt 26, 2006 1:32 pm
Wohnort: Bühl
Kontaktdaten:

Re: Käfer 2,7l Typ4

#76 Beitragvon porschekäfer » So Mai 12, 2019 7:15 pm

Anbei das erste Prüfstandsergebnis. Leider mussten wir abbrechen als es um die Optimierung der Vollast ging. Ist aber auch so schon nicht schlecht :D
Dateianhänge
DSC_0712.JPG
(912.02 KiB) Noch nie heruntergeladen
__________________________________
1600i ACD Käfer, MS2 V3.0 + eigene Erweiterungsplatinen + Alugehäuse, Lambda von Knödler, HC06 Bluetoothmodul
2,8 Typ4 Käfer, 45mm Drosselklappen, Spartan 2
http://www.porschekaefer.blogspot.com

Benutzeravatar
porschekäfer
Beiträge: 288
Alter: 40
Registriert: Do Okt 26, 2006 1:32 pm
Wohnort: Bühl
Kontaktdaten:

Re: Käfer 2,7l Typ4

#77 Beitragvon porschekäfer » Do Mär 19, 2020 11:06 pm

Hallo, mein Motor hat jetzt ca. 500km drauf. Er fährt eigentlich schon ganz gut mit Alpha-N. Aber ich habe einen Bereich, den bekomme ich nicht hin. Bei ca. 2000 -2500 U/min und bei ca. 30% TPS habe ich vielleicht Klingeln oder ein anderes Beschleunigungsgeräusch vom Motor. Der Motor will hier nicht so richtig. Vollast und niedrige Lasten sind super. Er zieht da einfach nicht richtig durch. Bin ich zu fett zu mager zu früh zu spät? Ich weiß es einfach nicht so richtig.
Im Log File habe ich die Stellen mit vielen Leerzeichen Tastenaktionen markiert.

Ich überlege jetzt, ob ich gleich auf ITB Mode gehe, damit ich nicht immer das Thema haben mit WOT. Ab ca 12% TPS ist bei der Drehzahl schon 90kPa erreicht. Ich habe 45mm Einzeldrosseln bei den 2,8l Motor.
Dateianhänge
2020-03-15_11.09.46.zip
(3.81 MiB) 36-mal heruntergeladen
CurrentTune.msq
(122.6 KiB) 28-mal heruntergeladen
__________________________________
1600i ACD Käfer, MS2 V3.0 + eigene Erweiterungsplatinen + Alugehäuse, Lambda von Knödler, HC06 Bluetoothmodul
2,8 Typ4 Käfer, 45mm Drosselklappen, Spartan 2
http://www.porschekaefer.blogspot.com

chapy
Beiträge: 1013
Registriert: Mi Feb 26, 2014 7:32 pm
Wohnort: Ur-Pilshausen

Re: Käfer 2,7l Typ4

#78 Beitragvon chapy » Fr Mär 20, 2020 11:55 am

also dein mapsignal ist doch recht gut.
ich würde das ign advance table auf map basiert umstellen.
gerade der bereich zwischen 2-3000rpm deiner tps basierten advance finde ich etwas stramm.
ggf so anpassen,daß ab 90kpa die volllast advance anliegt,je 10 kpa weniger map ca. 3° mehr advance.
wenn es sich so anfühlt,als würdest du in dem bereich mit angezogener handbremse beschleunigen,
bzw der motor sich sehr angestrengt und zugeschnürt mit vibrationen die sonst nicht da sind anfühlt,
wäre das für mich ein indiz für zuviel advance und das kann auf die lager gehen.

gruß chapy

Benutzeravatar
porschekäfer
Beiträge: 288
Alter: 40
Registriert: Do Okt 26, 2006 1:32 pm
Wohnort: Bühl
Kontaktdaten:

Re: Käfer 2,7l Typ4

#79 Beitragvon porschekäfer » Fr Mär 20, 2020 6:44 pm

Danke. Ich werde es mir so anschauen wie du es empfohlen hast. Dann werde ich es mit Map als Last probieren. Oder ich probiere den Itb Mode. Dann weiß ich auch wo Map 90kPa hat.

Wenn ich in Alpha N bleiben wollte hieße das, dass ich bis 90 kpa ( entsprechende TPS Werte) runter die Volllast Zündwinkel runter ziehen müsste. Erst bei kleinen TPS Werten ( kleiner 90kpa) wären dann die weitere Frühverstellung im Teillastbereich. Das würde ich auch gerne noch einmal probieren. Konsequent umgesetzt hieße das allerdings, dass ich die Load gleich auf Map stellen kann.

Danke und Gruß Jürgen
__________________________________
1600i ACD Käfer, MS2 V3.0 + eigene Erweiterungsplatinen + Alugehäuse, Lambda von Knödler, HC06 Bluetoothmodul
2,8 Typ4 Käfer, 45mm Drosselklappen, Spartan 2
http://www.porschekaefer.blogspot.com

chapy
Beiträge: 1013
Registriert: Mi Feb 26, 2014 7:32 pm
Wohnort: Ur-Pilshausen

Re: Käfer 2,7l Typ4

#80 Beitragvon chapy » Fr Mär 20, 2020 9:26 pm

die ganz schnelle methode ist ganz einfach eine zündkennlinie.
einfach die volllastwerte nach unten durchziehen fertig.
wie früher beim verteiler die unterdruckdose abziehen.

dein a/n kannst du ruhig lassen,stellenweise etwas großzügig fett,aber es ist ja auch ein lufti.
das sollte man die zylinderkopf-/öltemperatur im auge behalten.

bei der zündung halte ich es persönlich nach dem motto :
so wenig wie möglich,so viel wie nötig.
an etwas zu wenig advance und etwas zu fetter abstimmung,ist selten ein motor krepiert.
umgekehrt schon öfters.

Benutzeravatar
porschekäfer
Beiträge: 288
Alter: 40
Registriert: Do Okt 26, 2006 1:32 pm
Wohnort: Bühl
Kontaktdaten:

Re: Käfer 2,7l Typ4

#81 Beitragvon porschekäfer » Fr Mär 20, 2020 10:37 pm

Ja, ich stimme zu. Ich bin jetzt wieder zurück auf die üblichen Werte mit Verteiler. Die 90kPa Grenze habe ich via Logs ermittelt. Erst ab da, fange ich sachte an noch etwas Vorzündung zu geben. Das müsste jetzt konservativ genug sein. Wenn nicht dann ziehe ich nochmal 1-2 Grad ab und schaue ob er dann weniger "knirscht". Ich habe auch schöne Brennräume, große Zylinder 103mm, und Super Plus Benzin. Somit sollte er etwas Zündung vertragen. Aber ich stimme zu. Kann sein, dass der Motor es gar nicht braucht und man sollte wirklich nur so viel geben wie notwendig. Viel hilft hier nicht viel.
Wenn es dann immer noch nicht geht, muss ich die Benzinmenge variieren. Zu mager bin ich aber eigentlich nirgends :D Eher zu fett. Vielleicht mag er deshalb nicht.

Zündung_WOT_nachVerteiler.JPG
Zündung_WOT_nachVerteiler.JPG (89.35 KiB) 1473 mal betrachtet
,
__________________________________
1600i ACD Käfer, MS2 V3.0 + eigene Erweiterungsplatinen + Alugehäuse, Lambda von Knödler, HC06 Bluetoothmodul
2,8 Typ4 Käfer, 45mm Drosselklappen, Spartan 2
http://www.porschekaefer.blogspot.com

chapy
Beiträge: 1013
Registriert: Mi Feb 26, 2014 7:32 pm
Wohnort: Ur-Pilshausen

Re: Käfer 2,7l Typ4

#82 Beitragvon chapy » Sa Mär 21, 2020 12:56 am

das sieht doch schon besser aus.
fetter als afr 12.5 macht,meiner meinung nach,beim sauger keinen sinn.
ich kenne es noch von vergaserzeiten,wenn die bedüsung zu groß war und die unterdruckschieber voll offen waren,
rannte sie wie in eine gummiwand oberhalb von 9000rpm.
bei zu kleiner bedüsung,ließ die kraft linear zur steigenden rpm nach.
ich stimme bis zum drehmomentmax mit 13,danach bis zum leistungsmax fallend auf 12.5 ab.
damit habe ich die besten erfahrungen gemacht.

Benutzeravatar
porschekäfer
Beiträge: 288
Alter: 40
Registriert: Do Okt 26, 2006 1:32 pm
Wohnort: Bühl
Kontaktdaten:

Re: Käfer 2,7l Typ4

#83 Beitragvon porschekäfer » Di Mär 24, 2020 12:25 pm

Hallo, danke für die hilfreichen Anmerkungen.
13 bis zum Drehmomentmaximum --> d.h. z.B. Vollast zwischen 1700 bis 2500?
bis runter auf 12,5 bei Leistungsmaximum --> d.h. z.B. Vollast 2500 bis etwas vor Maxdrehzahl?

Ich bin gerade auch einer anderen Sache auf der Spur. Ich wollte meine EV messen bezüglich Totzeit. Dabei habe ich jetzt über 20% Durchflussunterschied an einer den neuen EV14 Bosch Einspritzventilen gefunden :(
Ich muss jetzt alle 4 noch einmal quervergleichen. Wenn das der Fall wäre, könnte es meine Problem auch erklären. Vielleicht war ein Zylinder immer an der mageren Grenze. Durch mein fettes Gesamtbild war das kaschiert, aber bei der Beschleunigung in meinem Problem Bereich hätte der eine Zylinder zu mager laufen können und dann entweder nicht mehr sauber laufen, oder sogar klingeln können. Ich hatte immer schon das Problem, dass er schon ab 14 anfing zu Patschen selbst in ganz niedrigen Lastbereichen. Ich dachte dann immer, dass ist halt so beim Luftgekühlten. Aber vielleicht liegt es ja auch dan dem einen EV oder anderen EV.

Ich werde es jetzt einfach genau analysieren. Semisequentiell und Zylindertrim ist bei der Abweichung ja nicht das Werkzeug der Wahl.

Danke für die Anregungen !!!!
__________________________________
1600i ACD Käfer, MS2 V3.0 + eigene Erweiterungsplatinen + Alugehäuse, Lambda von Knödler, HC06 Bluetoothmodul
2,8 Typ4 Käfer, 45mm Drosselklappen, Spartan 2
http://www.porschekaefer.blogspot.com

Benutzeravatar
porschekäfer
Beiträge: 288
Alter: 40
Registriert: Do Okt 26, 2006 1:32 pm
Wohnort: Bühl
Kontaktdaten:

Re: Käfer 2,7l Typ4

#84 Beitragvon porschekäfer » Di Mär 24, 2020 11:28 pm

Ich habe eine neuen Erkenntnis. Es muss an der Spannungsversorgung oder an der Ansteuerung der EV liegen.
Der Fehler (Megenunterschied 10% bei PW 7ms ) wandert mit wenn ich die EV-Stecker vertausche. Auf einer Bank ist immer ein Ventil das schon bei 0.5ms hörbar anfängt zu takten und eins das erst bei 1,5ms zu hören ist. Bei der anderen Bank ist es genau umgekehrt. An den EV's liegt es nicht. Die habe ich alle einmal durchgetauscht.

Ich habe eine UMC2. Je ein Ventil ist an einen der 4 Ausgänge angeschlossen. Ich fahren es "untimed", also immer zwei Ausgänge werden zusammen geschaltet.
Was kann ich tun außer umverkabeln?

Was mir gerade noch einfällt. Wie funktioniert das überhaupt. Woher weiß die MS eigentlich dass ich 4 Ausgänge habe wenn ich gar nicht diesen "Standard" auf "Additional Driver" gestellt habe? Zappeln die Ausgänge 3 und 4 dann nur als PWM Limiter Ausgänge mit? Wobei ich das PWM Current Limiting gar nicht aktiviert habe.

Ich bin verwirrt und ich glaube ich mache es falsch! Weiß das jemand? Sonst muss ich Peter mal kontaktieren.
__________________________________
1600i ACD Käfer, MS2 V3.0 + eigene Erweiterungsplatinen + Alugehäuse, Lambda von Knödler, HC06 Bluetoothmodul
2,8 Typ4 Käfer, 45mm Drosselklappen, Spartan 2
http://www.porschekaefer.blogspot.com

suzuki90
Beiträge: 917
Registriert: Mo Apr 11, 2011 5:24 pm

Re: Käfer 2,7l Typ4

#85 Beitragvon suzuki90 » Mi Mär 25, 2020 12:59 am

Hi,

also wenn du alle 4 Ausgänge nutzt, dann musst du auch additional Driver stellen.
Die PW testest du im Inj Test Mode?
Schau mal, dass alle Totzeit-Einstellungen für alle Düsen gleich sind. Da gab es mal einen Bug in der Firmware. Dazu muss man den Punkt aktivieren, dass man für jede Düse eigene Werte der Totzeit einstellen kann. Dann bei allen das gleiche rein und dann kann man das wieder deaktivieren, wenn man will.
Was hast du für einen Kabelquerschnitt? Mal die Spannung in den verschiedenen Steckern gemessen?

Wann spritzt der mit untimed ein? Immer in OT? Oder ist das dann schon eher batch fire?
Mazda MX5 NA 1.8 Turbo BorgWarner EFR 6258, MS3Pro :P :P :P
Coming soon: ITB, WLLK (Laminova), water injection

Benutzeravatar
porschekäfer
Beiträge: 288
Alter: 40
Registriert: Do Okt 26, 2006 1:32 pm
Wohnort: Bühl
Kontaktdaten:

Re: Käfer 2,7l Typ4

#86 Beitragvon porschekäfer » Mi Mär 25, 2020 7:56 am

Ja ich teste die Durchflüsse im Test Mode. In dem ich Inj 1 oder Inj 2 auswähle oder auch beide.
Die Einstellungen sind jetzt so:
Injector_Setting.JPG
(122.07 KiB) Noch nie heruntergeladen


Das mit den ausgegrauten Werte könnte den Unterschied erklären. Ich habe zwar überall 1ms Totzeit aber die Spannungskorrektur ist nicht überall gleich. Das werde ich ändern. Und prüfen ob es geht. Vermutlich wird es das sein. Danke!

Ich habe es auf untimed injection und weiß nicht wie im Vergleich zu OT er einspritzt. Nennt man das dann batch? Würde auch auf Semi Sequentiell wechsel, aber dann muss ich auf 4 Squirts per Engine Cycle umstellen. Ich weiß nicht ob dazu meine Düsen nicht zu groß sind. (347ccm und im Leerlauf habe ich 3,7ms warm)

Ich stelle auch auf "additional Driver". Ich dann nur gerne verstanden warum es jetzt auch schon geht, bzw. was sich dann ändert. Warum bekomme ich jetzt überhaut Signal an dem 3. und 4. Ausgang? Ich hatte die Frage schon bei der ersten Inbetriebnahme, aber irgendwie habe ich es dann fallen lassen weil es ja vermeintlich funktioniert hat.
__________________________________
1600i ACD Käfer, MS2 V3.0 + eigene Erweiterungsplatinen + Alugehäuse, Lambda von Knödler, HC06 Bluetoothmodul
2,8 Typ4 Käfer, 45mm Drosselklappen, Spartan 2
http://www.porschekaefer.blogspot.com

chapy
Beiträge: 1013
Registriert: Mi Feb 26, 2014 7:32 pm
Wohnort: Ur-Pilshausen

Re: Käfer 2,7l Typ4

#87 Beitragvon chapy » Mi Mär 25, 2020 5:47 pm

mit standart driver settings gehören die injectoren von
zylinder 1+3 auf inj.1
zylinder 2+4 auf inj.2
bei untimed 2 squirts/cycle alternated wird die volle benötigte spritmenge alle 360°kw abwechselnd von inj.1/inj.2 geliefert.
ergibt pro injectorpaarung 1 squirt/720°kw

bei semiseq mit additional driver gehören die injectoren von
zylinder 1 auf inj.1
zylinder 2 auf inj.4
zylinder 3 auf inj.3
zylinder 4 auf inj.2
wenn die zündfolge 1432 ist.
bei semiseq stellst auf 2 squirt/cycle simultan.
bei semiseq werden die inj.treiber 1+3 und 2+4 gleichzeitig betrieben.
es wird jeweils die halbe spritmenge pro 360°kw abwechselnd eingespritzt.
ergibt 2 squirts/720° für zylinder 1+3 bzw zylinder 2+4.

wie du schon richtig bemerkt hast,wird deine pw im warm idle dadurch sehr klein.
das kann leerlauf sägen mit unstabilen afr nach sich ziehen.

Benutzeravatar
porschekäfer
Beiträge: 288
Alter: 40
Registriert: Do Okt 26, 2006 1:32 pm
Wohnort: Bühl
Kontaktdaten:

Re: Käfer 2,7l Typ4

#88 Beitragvon porschekäfer » Mi Mär 25, 2020 11:07 pm

Danke euch allen für die Anmerkungen und Hilfe.
Ich denke, so lange ich keinen Nockenwellensensor habe lasse ich es dann erst mal so.

Ich habe noch einmal die Einspritzmengen gemessen und auch mit einem Oszi die Signale angeschaut.
So soll es aussehen bei 1ms PW:
IMG_0886.jpg
(878.53 KiB) Noch nie heruntergeladen


So hat es ausgesehen wenn man nicht auf "Advanced Driver" umgestellt hat:
IMG_0885.jpg
(919.04 KiB) Noch nie heruntergeladen


Der Puls war etwas länger. Bei kleinen PW Werten hat das aber etwas ausgemacht im Vergleich zu den Ausgängen 1 und 2.
Jetzt passt es gut. Bei unterschiedlichen PW Werten war die Spritmenge am Ende bis auf 1% gleich.
IMG_0888.jpg
(999.68 KiB) Noch nie heruntergeladen
__________________________________
1600i ACD Käfer, MS2 V3.0 + eigene Erweiterungsplatinen + Alugehäuse, Lambda von Knödler, HC06 Bluetoothmodul
2,8 Typ4 Käfer, 45mm Drosselklappen, Spartan 2
http://www.porschekaefer.blogspot.com

Benutzeravatar
porschekäfer
Beiträge: 288
Alter: 40
Registriert: Do Okt 26, 2006 1:32 pm
Wohnort: Bühl
Kontaktdaten:

Re: Käfer 2,8l Typ4

#89 Beitragvon porschekäfer » Sa Mai 02, 2020 7:13 pm

So, der Motor läuft jetzt ruhiger. Durch die Einstellungsänderung auf "Additional Driver" musste ich die VE ca. 10% fetter stellen.
Ich habe dann ITB Modus gewechselt, da ich die VE ja eh neu machen musste. Das hat auch ganz gut geklappt. Es gibt aber noch viel abzustimmen.
Wahrscheinlich stimmt der Switchpoint noch nicht ganz. Es ist auch etwas spürbar, dass man wie gegen eine Art Schwelle fährt bei niedrigen Drehzahlen. Man muss das Gas erst noch etwas weiter drücken um quasi darüber weg zu kommen. Also ist da die VE noch nicht ganz richtig. Die Luft wird ja manuell mit der der Klappe gemacht :D

Man hat in der VE aber schon einen starken Gradienten wischen dem MAP Bereicht (Load 0 - 50%) und TPS Bereich (Load 50% - 100%). Ich muss da wahrscheinlich noch mehr VE Auflösung spendieren und wahrscheinlich die Switchpointkurve noch einmal anpassen. Ich hatte sie aber aus einer recht großen Datenlogmenge bestimmt (MAP = 90kPa).
ITB_AFR_VE.JPG
(116.97 KiB) Noch nie heruntergeladen


Pos_Load.JPG
Pos_Load.JPG (152.81 KiB) 920 mal betrachtet
__________________________________
1600i ACD Käfer, MS2 V3.0 + eigene Erweiterungsplatinen + Alugehäuse, Lambda von Knödler, HC06 Bluetoothmodul
2,8 Typ4 Käfer, 45mm Drosselklappen, Spartan 2
http://www.porschekaefer.blogspot.com

suzuki90
Beiträge: 917
Registriert: Mo Apr 11, 2011 5:24 pm

Re: Käfer 2,7l Typ4

#90 Beitragvon suzuki90 » Di Mai 05, 2020 8:19 am

Warum ist die AFR Tabelle so stark unregelmäßig? Und über einen Großteil des Teillast Betrieb so fett?
Läuft der sonst nicht ordentlich?
Mazda MX5 NA 1.8 Turbo BorgWarner EFR 6258, MS3Pro :P :P :P
Coming soon: ITB, WLLK (Laminova), water injection


Zurück zu „Erfolgsstorys / Ein-Umbaudokus“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 22 Gäste