www.MegaSquirt.de

Das deutschsprachige MegaSquirt-Forum

BMW M20 - mit Rotrex-Kompressor - Leerlauf macht mich fertig

Link zur MegaSquirt'nSpark Homepage
Nachricht
Autor
Benutzeravatar
Alfagta
Beiträge: 1880
Alter: 96
Registriert: Mo Jan 24, 2011 2:24 pm
Kontaktdaten:

Re: BMW M20 - mit Rotrex-Kompressor - Leerlauf macht mich fertig

#61 Beitragvon Alfagta » Di Jul 26, 2016 7:20 am

Hier noch die Bilder von der MS vor und nach der Reperatur...
Dateianhänge
k-Treiber für LLR (gesockelt).JPG
k-Treiber für LLR (gesockelt).JPG (347.94 KiB) 1805 mal betrachtet
k-LLR Ausgänge, nachher.JPG
k-LLR Ausgänge, nachher.JPG (240.25 KiB) 1805 mal betrachtet
k-Leitung direkt zu Pin.JPG
k-Leitung direkt zu Pin.JPG (281.31 KiB) 1805 mal betrachtet
k-Leiterbahn weggeschmolzen.jpg
k-Leiterbahn weggeschmolzen.jpg (173.15 KiB) 1805 mal betrachtet
k-Leiterbahn defekt.jpg
k-Leiterbahn defekt.jpg (219.61 KiB) 1805 mal betrachtet
Wer aufhört besser zu werden hat aufgehört gut zu sein
Alfa 156 GTA
Alfa 75 Race Car MS III -- alway latest FW
Alfa 164 V6 Turbo
Test MS II --always latest FW
Tunerstudio V3.0.18 Registered
MLog View V4.1.12 Registered
MLog View HD V4.1.12 Registered

Benutzeravatar
Alfagta
Beiträge: 1880
Alter: 96
Registriert: Mo Jan 24, 2011 2:24 pm
Kontaktdaten:

Re: BMW M20 - mit Rotrex-Kompressor - Leerlauf macht mich fertig

#62 Beitragvon Alfagta » Di Jul 26, 2016 7:21 am

Und der Rest...
Dateianhänge
k-Belegung Deckel innen.JPG
k-Belegung Deckel innen.JPG (195.77 KiB) 1803 mal betrachtet
k-Verkabelung LLR Treiber.JPG
k-Verkabelung LLR Treiber.JPG (277.45 KiB) 1803 mal betrachtet
k-Übersicht Vorderseite, nachher.JPG
k-Übersicht Vorderseite, nachher.JPG (318 KiB) 1803 mal betrachtet
k-Übersicht Rückseite, nachher.JPG
k-Übersicht Rückseite, nachher.JPG (321.54 KiB) 1803 mal betrachtet
Wer aufhört besser zu werden hat aufgehört gut zu sein
Alfa 156 GTA
Alfa 75 Race Car MS III -- alway latest FW
Alfa 164 V6 Turbo
Test MS II --always latest FW
Tunerstudio V3.0.18 Registered
MLog View V4.1.12 Registered
MLog View HD V4.1.12 Registered

Benutzeravatar
franksidebike
Beiträge: 3396
Registriert: So Apr 03, 2005 6:28 pm
Wohnort: http://de.wikipedia.org/wiki/Wathlingen

Re: BMW M20 - mit Rotrex-Kompressor - Leerlauf macht mich fertig

#63 Beitragvon franksidebike » Di Jul 26, 2016 8:41 pm

Norman-E34 hat geschrieben:@Frank: Hab die Dead-Time aus der Deadtime-Database von e30tech.com, habe die Düsen, u.a. Gründen, sogar extra gekauft weil da von relativ vielen Usern die Deadtime zu bestätigt wurde.

Bei mir hat das nie richtig gepasst was auf den datenblättern steht, für mich war das nur ein grober Anhaltspunkt.
frank

Benutzeravatar
ChristianK
Beiträge: 1904
Alter: 94
Registriert: So Jun 29, 2014 8:53 pm

Re: BMW M20 - mit Rotrex-Kompressor - Leerlauf macht mich fertig

#64 Beitragvon ChristianK » Di Jul 26, 2016 8:49 pm

Mario, was ist denn ein K-Treiber?

Frank, sehe ich auch so. Bei meinen Düsen haben sich an Stelle von 315cc und 0,9ms laut Datenblatt 345cc und knapp 1,4ms herauskristallisiert.

Gleiches bei anderen Düsen. Mit Deiner ätzend langwierigen Tabelle bin ich bisher am besten gefahren.

Benutzeravatar
Alfagta
Beiträge: 1880
Alter: 96
Registriert: Mo Jan 24, 2011 2:24 pm
Kontaktdaten:

Re: BMW M20 - mit Rotrex-Kompressor - Leerlauf macht mich fertig

#65 Beitragvon Alfagta » Di Jul 26, 2016 9:25 pm

K-Treiber ist nur der Bild Name. K weil die verkleinert wurden fürs Forum
Wer aufhört besser zu werden hat aufgehört gut zu sein
Alfa 156 GTA
Alfa 75 Race Car MS III -- alway latest FW
Alfa 164 V6 Turbo
Test MS II --always latest FW
Tunerstudio V3.0.18 Registered
MLog View V4.1.12 Registered
MLog View HD V4.1.12 Registered

Benutzeravatar
ChristianK
Beiträge: 1904
Alter: 94
Registriert: So Jun 29, 2014 8:53 pm

Re: BMW M20 - mit Rotrex-Kompressor - Leerlauf macht mich fertig

#66 Beitragvon ChristianK » Di Jul 26, 2016 9:41 pm

Ach so. Ich dachte, damit wäre der ic in der proto gemeint. Was ist das für ein ic? TC-4427 und oben a b c sind die Düsenausgänge? Hast Du nur den LLR gefixt?

Benutzeravatar
Norman-E34
Beiträge: 45
Registriert: Di Jul 10, 2012 9:52 pm
Wohnort: Weinstadt

Re: BMW M20 - mit Rotrex-Kompressor - Leerlauf macht mich fertig

#67 Beitragvon Norman-E34 » Di Jul 26, 2016 9:47 pm

@ Frank: Die Seite ist leider down wo ich das her habe, komisch, aber das waren gemessene Werte, die auch von verschiedenen Nutzern bestätigt wurden.

Bosch 0280155203:
High impedance, Mercedes Benz 5.0l V8
.85ms @ 13.8v
1.5ms @ 8.66v
Battery voltage correction: .13ms/v
Flow rate: 203cc/min @ 42psi (3bar)

Habe sie aber nicht direkt noch mal im Fahrzeug nachgemessen, vllt. sollte ich das mal noch bei Gelegenheit nachholen.

Ich muss mich morgen noch mal intensiv mit dem VE-Kennfeld beschäftigen ob der jetzt wirklich einfach zu fett läuft und deshalb ausgeht. Mich wundert es dass der so gut angesprungen ist und dann nach dem die ASE fertig mit der Anreicherung ist geht der Bock aus, kam heute leider nicht dazu. Aber das ist echt merkwürdig.. auch nach 4 oder 5 mal starten ist es das gleiche.

PS: Wirklich gute Arbeit von Mario, bin ihm sehr dankbar dafür! :wink:

Benutzeravatar
Alfagta
Beiträge: 1880
Alter: 96
Registriert: Mo Jan 24, 2011 2:24 pm
Kontaktdaten:

Re: BMW M20 - mit Rotrex-Kompressor - Leerlauf macht mich fertig

#68 Beitragvon Alfagta » Di Jul 26, 2016 10:17 pm

TC4428 weil ein Ausgang invertiert sein muss.

ABC sind die spulen.

Gruß
Wer aufhört besser zu werden hat aufgehört gut zu sein
Alfa 156 GTA
Alfa 75 Race Car MS III -- alway latest FW
Alfa 164 V6 Turbo
Test MS II --always latest FW
Tunerstudio V3.0.18 Registered
MLog View V4.1.12 Registered
MLog View HD V4.1.12 Registered

Benutzeravatar
franksidebike
Beiträge: 3396
Registriert: So Apr 03, 2005 6:28 pm
Wohnort: http://de.wikipedia.org/wiki/Wathlingen

Re: BMW M20 - mit Rotrex-Kompressor - Leerlauf macht mich fertig

#69 Beitragvon franksidebike » Mi Jul 27, 2016 9:20 am

hallo norman
Norman-E34 hat geschrieben:@ Frank: .............., komisch, aber das waren gemessene Werte, die auch von verschiedenen Nutzern bestätigt wurden.

das problemchen ist wohl das verschiedene düsentreiber eben verschieden Dead Times verursachen, die düsen oder datenblätter sind nicht an den unterschiedlichen Ergebnissen schuld!
der einfachste weg ist: zwischen zwei und vier Squirts hin und her stellen bis sich der afr nicht mehr ändert und für die BattV corr. Verbraucher an/aus ohne das sich der afr ändert. dann passt es zu deinen treibern, kabeln, düsen......
Gruß Frank

Benutzeravatar
Norman-E34
Beiträge: 45
Registriert: Di Jul 10, 2012 9:52 pm
Wohnort: Weinstadt

Re: BMW M20 - mit Rotrex-Kompressor - Leerlauf macht mich fertig

#70 Beitragvon Norman-E34 » Sa Jul 30, 2016 1:17 pm

Hallo Kollegen :)

Jetzt war es ein paar Tage ruhig um mich, aber ich habe gute Nachrichten.. deutliche Verbesserung ! Offensichtlich wars ihm mit der ASE und WarmUp tatsächlich zu fett.. Ich habe viel Zeit damit verbracht die VE in zwei Zeilen mit dem gleichen Wert zu füllen, das hat leider nicht geklappt.. so das letztendlich mein VE-Table im LL-Bereich so aussieht.

Bild

Mit der ASE und auch dem Warmlauf das funktioniert noch nicht so ganz bei allen Temperaturen, aber da muss ich jetzt einfach noch mal Zeit investieren.

Funktioniert aber mit Lüfter und ohne Lüfter so ganz gut. Im LOG-File ist der Lüfter auch angesprungen, das sieht man ganz gut. Was ich jetzt noch gerne hätte ist, dass die Lambdakorrektur ihn immer auf mein Wunschlambda zieht und das relativ schnell - da das doch manchmal noch etwas schwankt, ihr sehr in dem Log dass ich zwei mal "geburned" habe (deshalb auch die 2 Lost Sync Counts), da habe ich die EGO-Correction wieder aktiviert und beim zweiten mal von PID-Algorithmus auf Simple umgestellt. Habt ihr Tipps dafür wie ich eine schnelle und gute Lambdaregelung hinbekomme? Da kommt jetzt weder der PID-Kram ins Spiel... :roll: Der Simple-Algorithmus scheint es da nicht rauszureißen.

PS: InjectorDeadTime: Ich kann nicht zwischen zwei und vier Squirts hin und her stellen, fahre 2 Squirts Alternating am 6 Zylinder.. ich müsste zwischen 2 und 6 Squirts Alternating schalten, das sollte das gleiche Ziel ergeben oder gibt es da Schwierigkeiten!?
Dateianhänge
CurrentTune.msq
(110.92 KiB) 37-mal heruntergeladen
20160730_LL_modified.msl
(1.02 MiB) 35-mal heruntergeladen

chapy
Beiträge: 706
Registriert: Mi Feb 26, 2014 7:32 pm
Wohnort: Ur-Pilshausen

Re: BMW M20 - mit Rotrex-Kompressor - Leerlauf macht mich fertig

#71 Beitragvon chapy » So Jul 31, 2016 9:57 pm

hab mal kurz angeschaut ?
wenn du tableswitching nutzen willst,um die achsen zu erweitern,dann macht man das eigentlich nicht so wie du.
2 squirts/alternate oder 2 squirts/simulatan mit 1/2 reqfuel im unteren feld.

Benutzeravatar
Norman-E34
Beiträge: 45
Registriert: Di Jul 10, 2012 9:52 pm
Wohnort: Weinstadt

Re: BMW M20 - mit Rotrex-Kompressor - Leerlauf macht mich fertig

#72 Beitragvon Norman-E34 » Mo Aug 01, 2016 2:15 pm

Hallo Chapy,

Kannst du kurz näher erläutern was du genau meinst?

Fahre 2 squirts / alternating und fahre zwei einspritz- und zwei zündkennfelder die jeweils ein großes, ganzes Kennfeld ergeben - korrekt. Du meinst ich sollte auf 2sq-simult. umschalten für die deadtime Ermittlung?

chapy
Beiträge: 706
Registriert: Mi Feb 26, 2014 7:32 pm
Wohnort: Ur-Pilshausen

Re: BMW M20 - mit Rotrex-Kompressor - Leerlauf macht mich fertig

#73 Beitragvon chapy » Mo Aug 01, 2016 9:14 pm

rotrex-mod-ohne gewähr.msq
(110.9 KiB) 33-mal heruntergeladen
wieviel ladederuck willst du mit den kleinen düsen erreichen ?
wenn ich das mal über den daumen peile,bin ich bei 5000U/min und 120 kpa map bei 85%DC @12.5 afr,mit 203ccm/min düsen :|
solltest du die squirts nicht ständig umstellen,ist die absolut exakte deadtime nicht so wild,ob die nun auf die letzten kommastelle stimmt oder nicht,macht den bär nicht fett.
die spannungskorrektur ist wichtiger,die sollte schon sehr exakt passen (meine meinung)
warum ist die baro und air mat density cor genullt ? überall 100 ?
hab mal das ve und ign table umgefrickelt,
aber in ve 3 und ign 3 sind fantasiewerte !!!

Benutzeravatar
Norman-E34
Beiträge: 45
Registriert: Di Jul 10, 2012 9:52 pm
Wohnort: Weinstadt

Re: BMW M20 - mit Rotrex-Kompressor - Leerlauf macht mich fertig

#74 Beitragvon Norman-E34 » Di Aug 02, 2016 7:19 am

Guten Morgen :D ,

jetzt hab ichs kapiert, manchmal sieht man einfach den Wald vor lauter Bäumen nicht. Ich dachte irgendwie immer TableSwitching funktioniert nur mit Hardware-Schalter, ich kam nie auf die Idee mal zu schauen ob da auch andere Trigger-Events hinterlegt sind.

Ich habe meine Tables jetzt mal dahingehend angepasst. VE1 endet mit 4.000 1/min und VE3 beginnt mit 4.001 1/min, bei TableSwitiching-Event >4.000 1/min. Für die Zündung hab ich es ähnlich gemacht. Aber das sollte an der Funktion der Tables zu bisher eigtl. nichts geändert haben, oder doch?

Ich fahre in der Spitze um die 150kpa. Hatte vorher 440er Düsen für 1,1bar Turbo-geladen. Hatte bis jetzt auch noch keine Probleme mit den Düsen, die hatten den Charm dass man Sie recht günstig bekommt und eben die Daten dazu auffindbar waren. Ich gehe jetzt mal davon aus dass die BatteryCorrection stimmt, ermittel ich die genau so? Wenn man da so drüber nach denkt, würde aber bei dieser Prozedur nie eine Düse auffallen die etwas mehr oder etwas weniger macht in dem 3er-Verbund. Das kann ja auch zu Lambda-Schwankungen führen, normalerweise müsste man die alle einzeln mal richtig auf ner kleinen Testbench untersuchen hm. Gibt es mit der Megasquirt schon die Möglichkeit, dass man einzelne Düsen mehr oder weniger ansteuern kann um die Kleinstmengenkalibrierung durchzuführen? Nicht dass ich das bräuchte, weil ich ja meine nicht mal richtig untersucht habe, aber interessant wäre das ja schon.

Air mat density ist genullt weil ich die Vermutung hatte meine Motorraumerwärmung im Stand und die anschließende Korrektur der Megasquirt über die MAT verschlechtert mir den LL so.. Hab die Kurve wieder eingefügt, danke für den Hinweis! Barr.Cor. war allerdings schon immer 0 bei mir, brauch ich das? :mrgreen:

Lieben Gruß!

Benutzeravatar
Norman-E34
Beiträge: 45
Registriert: Di Jul 10, 2012 9:52 pm
Wohnort: Weinstadt

Re: BMW M20 - mit Rotrex-Kompressor - Leerlauf macht mich fertig

#75 Beitragvon Norman-E34 » Mo Aug 15, 2016 9:19 pm

Hallo liebe Mitleser und Helfer,

Kurzer Zwischenstand: Leerlauf hat sich noch etwas weiter verbessert indem ich die pwm Vorgaben für den llr genauer angepasst habe. Ich habe den Drehzahlen entsprechend Werte eintragen, Ersteinmal grob ohne auf die Temperaturen zu achten, wäre jetzt mein nächster Schritt gewesen.. ABER:

Mir hat es gestern meine kurbelwellenriemenscheibe abgeschert. Mein kompressorhalter wollte ich jetzt im Winter noch versteifen, der hat bei lastwechseln leicht mitgeschwungen und das über den Riemen übertragen, dadurch müssen sich die Schrauben gelockert haben, ich hatte keine schraubensicherung dran, die war alle zu dem Zeitpunkt :O. Zwei Schrauben waren weg, die restlichen abgeschert. Die Scheibe hat es einen Abhang runter geschleudert. Das hätte auch schief gehen können. Jetzt muss ich erstmal die kW Scheibe neutralen lassen und meine diemensionierung werde ich auch etwas anpassen, so dass ich eher auf meinen maximalladedruck komme.

Danach werde ich mal wieder meine aktuelle config und eine Messung reinstellen, ich hoffe das hilft dann auch noch anderen weiter die ihren Leerlauf verbessern wollen. Im Vergleich zu den Anfängen waren die Tips hier in diesem thread das pure Gold.


Zurück zu „MegaSquirt 'n Spark / MSExtra / MS2Extra“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast