www.MegaSquirt.de

Das deutschsprachige MegaSquirt-Forum

Ladedruckregelung schwingt

Hier könnt ihr MegaTune downloaden
Nachricht
Autor
Benutzeravatar
Alfagta
Beiträge: 2134
Alter: 98
Registriert: Mo Jan 24, 2011 2:24 pm
Kontaktdaten:

Re: Ladedruckregelung schwingt

#16 Beitragvon Alfagta » Di Okt 04, 2016 10:04 pm

Kann es sein das der Boost Duty zwischen den Initial werten hin und her springt?
Wer aufhört besser zu werden hat aufgehört gut zu sein
Alfa 156 GTA
Alfa 75 Race Car MS III -- alway latest FW
Alfa 164 V6 Turbo
Test MS II --always latest FW
Tunerstudio V3.0.18 Registered
MLog View V4.1.12 Registered
MLog View HD V4.1.12 Registered

Cali-LET
Beiträge: 657
Registriert: Di Jun 10, 2008 10:37 pm

Re: Ladedruckregelung schwingt

#17 Beitragvon Cali-LET » Di Okt 04, 2016 10:23 pm

Sowas ähnliches hatte ich auch mal. Deswegen hab ich seit dem immer die oberen Zeilen immer gleich mit unterschiedlichen TPS Werten.

Bild

Der Log und die MSQ dazu wäre aber mal interessant. Also welchen Initwert er da nimmt und nicht doch irgendwo die 90% aus dem "Lower Limit delta" dazwischen spuckt. Bin aber wie gesagt auch eher der Open Loop fahrer. :lol:
VR6 Turbo mit EFR Twinscroll und UMC1 im Seriengehäuse

suzuki90
Beiträge: 857
Registriert: Mo Apr 11, 2011 5:24 pm

Re: Ladedruckregelung schwingt

#18 Beitragvon suzuki90 » Mi Okt 05, 2016 12:26 am

Anbei der Log und die msq.

Lower Limit Delta steht bei 20 kPa. Man sieht das im Log schön. Die Boost Duty liegt bei 90 %, bis 20 kPa vor Target (ca 203 kPa). Da geht mit Beginn der Boostregelung die Boost DC kurz auf 5%, was ich schon nicht verstehe. Und dann wird geschwungen, was das Zeug hält, allerdings eben immer in einer Amplitude, die merklich über dem Lower Limit Delta liegt.
habe weder bei Initial Value noch beim Target gleiche Werte in den beiden oberen Zeilen...
Dateianhänge
CurrentTune.msq
(114.03 KiB) 72-mal heruntergeladen
2016-10-03_16.58.02_CL-Boost.msl
(526.61 KiB) 64-mal heruntergeladen
Mazda MX5 NA 1.8 Turbo BorgWarner EFR 6258, MS3Pro :P :P :P
Coming soon: ITB, WLLK (Laminova), water injection

Zaphod
Beiträge: 91
Registriert: Fr Aug 13, 2010 9:27 am

Re: Ladedruckregelung schwingt

#19 Beitragvon Zaphod » Mi Okt 05, 2016 8:41 am

suzuki90 hat geschrieben:Da geht mit Beginn der Boostregelung die Boost DC kurz auf 5%, was ich schon nicht verstehe.


Du hast ja bei Closed duty 5% drin stehen, deshalb auch die 5 % als Startregelung.

Edit: Grade mal deine MSQ noch kurz angeguckt - versuch mal bitte die oberste Initial duty Zeile nicht auf 250 zu setzen sondern auf 230 (da du ja 225 als Target hast) und dort auch die gleichen Werte rein wie bei der 225er Zeile (oder 1% höher). Der Wert springt dort im log immer zwischen den beiden Zeieln 225 und 250 hin und her - und da sind fast 10 % UNterschied im Initial duty.
Zuletzt geändert von Zaphod am Mi Okt 05, 2016 8:50 am, insgesamt 1-mal geändert.
fun is not a straight line

Bild

Sven

http://miata.cardomain.com/id/svenmx5
NB-1998-1,9VVT swap - EFR 6258 Turbo@ 1,2bar

Benutzeravatar
Alfagta
Beiträge: 2134
Alter: 98
Registriert: Mo Jan 24, 2011 2:24 pm
Kontaktdaten:

Re: Ladedruckregelung schwingt

#20 Beitragvon Alfagta » Mi Okt 05, 2016 8:47 am

Hallo,

also grundsätzlich ist es so wenn du auf Basic Tuning Mode stellst sind die P,I,D werte intern alle auf 10.0.
Den 0 würde ja nicht funktionieren (der P,I,D regler funktioniert nunmal nicht mehr mit 0 werten).

Warum der da sobald er im Regel Bereich ist (Target - Delta) auf 5% Duty springt ist wohl ein kleiner Bug.
Es gibt nur 2 möglichkeiten das er auf 0 geht. Entweder wenn MAP < Baro -50 ist oder wenn ASE bzw. Cranking aktiv ist.
Immer dann wird fix der min Duty verwendet.
Sobald du aber im Fenster bist geht er in den Regelkeis, dann wird alles auf initialwerte gesetzt. Da wird dann ein Kp Wert von 0 berechnet was den SP ja ins nirvana treibt.
Deshalb wird es mit dem Min Duty abgefangen. Beim nächsten Loop geht es dann wirklich los weil erst da wir korrekt berechnet.

Ja und deine Regelung schwingt eigentlich nicht außerhalb der Grenzen so wie du meinst?! Du bist immer im Delta.

Nur mal so aus interesse welchen Map Sensor verwendest du?
Wer aufhört besser zu werden hat aufgehört gut zu sein
Alfa 156 GTA
Alfa 75 Race Car MS III -- alway latest FW
Alfa 164 V6 Turbo
Test MS II --always latest FW
Tunerstudio V3.0.18 Registered
MLog View V4.1.12 Registered
MLog View HD V4.1.12 Registered

Benutzeravatar
franksidebike
Beiträge: 3504
Registriert: So Apr 03, 2005 6:28 pm
Wohnort: http://de.wikipedia.org/wiki/Wathlingen

Re: Ladedruckregelung schwingt

#21 Beitragvon franksidebike » Mi Okt 05, 2016 10:28 am

morgen
suzuki90 hat geschrieben:Lower Limit Delta steht bei 20 kPa. Man sieht das im Log schön. Die Boost Duty liegt bei 90 %, bis 20 kPa vor Target (ca 203 kPa).

an dieser stelle hätte der boost duty auf den wert aus deinem initial tabel springen sollen (etwa 59%).
Da geht mit Beginn der Boostregelung die Boost DC kurz auf 5%, was ich schon nicht verstehe.

das ist so nicht ok?
ich habe die Funktion "Basic" noch nie benutzt und denke da ist ein fehler drin!
Und dann wird geschwungen, was das Zeug hält, allerdings eben immer in einer Amplitude, die merklich über dem Lower Limit Delta liegt.

das schwingen an sich ist so richtig, er versucht ja sein ziel zu erreichen, solange der map nicht unter deinem Boost target minus lower Limit Delta fällt ist die Regelung aktiv (Target 225-delta 20=205).
ich würde so weiter machen:
dein Initial tabel scheint in etwa so zu passen.
Advanced mode an, closed Loop sensitivity Slider kleiner (50), P, I, D, auf 0 oder sehr klein, dann sollte die Regelung sehr träge sein und du kannst so auch erkennnen ob deine initial werte richtig sind, von der Einstellung aus die P,I,D, und den slider langsam erhöhen bis die Regelung schnell genug ist.
Frank

suzuki90
Beiträge: 857
Registriert: Mo Apr 11, 2011 5:24 pm

Re: Ladedruckregelung schwingt

#22 Beitragvon suzuki90 » Mi Okt 05, 2016 12:07 pm

Danke schonmal für die Inputs.

Nochmal kurz zur Erklärung: Ich hatte ja Advanced aktiviert mit PID was letztes Jahr noch meistens Schwingungsfrei funktioniert hat. Da war auch die Inital Value Tabelle so. Würde auch nicht verstehen, wenn ich bei zwei unterschiedlichen Targets die gleiche Boost Duty hinterlegen sollte, denn der schaut ja auf das Target und nimtm sich daraufhin den Initial Value. Nachdem Target keinbisschen schwankt sondern fest bleibt, hat der auch einen festen Initial Wert, da der den ja nicht nach dem aktuellen Map wählt sondern nach dem Target Map.
Jedenfalls hat er dann so wie auf dem Log begonnen zu schwingen, deshalb haben wir die P,I udn D regler zurück genommen, solange, bis alle 3 auf 0 standen. Hat aber NICHTS geändert am schwingen. Also haben wir den Scheiberegler noch zurück genommen, in Schritten, bis dieser dann auch auf 0 stand. Ohne Änderung. Dann hab ich auf Basic gestellt, keine Änderung, und für den Log jetzt den Regler wieder auf 100 gestellt.

die 5% mögen passen, stören auch erstmal nicht.
Fakt ist, was @Alfagta schon schreibt (und ich weiter oben auch so meinte) nachdem er während des Schwingens nicht unter das Delta kommt, bleibt die Ladedruckregelung immer aktiv. Er regelt ja auch, aber schwingend. Was mir nicht in den Kopf geht, ist warum eine krasse Verstellung der P,I,D Regler zwischen 0 und 100 KEINE Änderung der Ladedruckregelung bewirkt. Da muss doch irgendwas faul sein. Zumal ich ja inzwischen eine neuere Firmware drauf habe... Es ist, als übersehe ich etwas. Sobald ich auf open loop stelle passt alles.
Klar, kann ich auch mit open loop fahren. War aber nicht Ziel der Aufgabe...
Mazda MX5 NA 1.8 Turbo BorgWarner EFR 6258, MS3Pro :P :P :P
Coming soon: ITB, WLLK (Laminova), water injection

Zaphod
Beiträge: 91
Registriert: Fr Aug 13, 2010 9:27 am

Re: Ladedruckregelung schwingt

#23 Beitragvon Zaphod » Mi Okt 05, 2016 1:43 pm

Mal so ein Gedanke - dein TPS springt (fast in Correlation mit den Boost duty cycle -Sprüngen) immer mal über die 100 % raus auf 100,1 oder 100,2 - kann es sein, das hier irgendeine Extrapolation stattfindet, die wiederum den Target wert/Initial duty o.ä. irgendwie zerschießt, oder so was in der Richtung?
fun is not a straight line

Bild

Sven

http://miata.cardomain.com/id/svenmx5
NB-1998-1,9VVT swap - EFR 6258 Turbo@ 1,2bar

suzuki90
Beiträge: 857
Registriert: Mo Apr 11, 2011 5:24 pm

Re: Ladedruckregelung schwingt

#24 Beitragvon suzuki90 » Mi Okt 05, 2016 4:08 pm

Hm, kann ich mir nicht vorstellen, aber lässt sich ja durch eine etwas andere Kalibrierung leicht überprüfen.
Mazda MX5 NA 1.8 Turbo BorgWarner EFR 6258, MS3Pro :P :P :P
Coming soon: ITB, WLLK (Laminova), water injection

suzuki90
Beiträge: 857
Registriert: Mo Apr 11, 2011 5:24 pm

Re: Ladedruckregelung schwingt

#25 Beitragvon suzuki90 » Mi Nov 02, 2016 9:32 am

Also, kann hier mal wieder was kurzes schreiben.

Gleich vorab: Dank Saison-Kennzeichen kann ich seit gestern eh nichts mehr testen. ;-)

Die Drosselklappeneinstellung hat keinen Einfluss, ebenso, wie die Initial Table in den oberen beiden Zeilen eingestellt ist sowie das Target Table. Würde mir auch nicht gefallen, da bei 90 und 100 % TPS die gleichen Werte zu haben. Ich mag den Ladedruck schön linear am Gaspedal.

Was mir aber im Log aufgefallen ist: Bei Volllast (da wo mit closed loop auch die Ladedruckregelung schwingt) setzt immer wieder die Beschleunigungsanreicherung ein und aus. (Also auch deccel) Obwohl ich den Grenzwert auf 180 kPa/sec gesetzt habe. Zu diesem Zeitpunkt steht konstant Ladedruck an, es gibt also erstmal keine Änderung und die Beschleunigungsanreicherung wird aufgrund Map-AE/Map-DE gemacht.
Schaut man sich dann MAPdot an, sieht man starke Schwankungen. Also ein ziemliches Signalrauschen.
Dieses Rauschen ist aber von der Frequenz so, dass es im Map-Wert kaum auffällt. Ich vermute aber, dass dies eben meine Ladedruckregelung aus der Bahn wirft, je nachdem, wo eben abgetastet wird.
Jetzt ist die Frage: Woher dieses Rauschen? Der Map-Sensor ist fest auf der UMC2 verbaut, kann also kein falsches Kabel verlegt haben. Dass die Luft in dem Schlauch zwischen ASB und Sensor so zu schwingen beginnt, kann ich mir auch schwer vorstellen.
Ich werde nächstes Jahr mal mit dem Smoothing-Wert bissle spielen. Der steht bisher auf 60. Wenn ich da runter auf 30 gehe, sollte das eigentlich weg sein. Und die Beschleunigungsanreicherung eh nur noch zu 100% über TPS bzw den Map-Wert deutlich höher setzen.
Mazda MX5 NA 1.8 Turbo BorgWarner EFR 6258, MS3Pro :P :P :P
Coming soon: ITB, WLLK (Laminova), water injection

Zaphod
Beiträge: 91
Registriert: Fr Aug 13, 2010 9:27 am

Re: Ladedruckregelung schwingt

#26 Beitragvon Zaphod » Do Nov 03, 2016 5:57 pm

Da kannst du dann auch mal probieren, so einen kleinen Benzinfilter in die Map-Leitung zur MS als Dämpfer einzubauen.

https://conceptzperformance.com/Cart/images/9627l.jpg

Ist meist bei den Blow off valves dabei...
fun is not a straight line

Bild

Sven

http://miata.cardomain.com/id/svenmx5
NB-1998-1,9VVT swap - EFR 6258 Turbo@ 1,2bar

suzuki90
Beiträge: 857
Registriert: Mo Apr 11, 2011 5:24 pm

Re: Ladedruckregelung schwingt

#27 Beitragvon suzuki90 » Do Nov 03, 2016 8:41 pm

Stimmt, wäre einen Versuch wert...
Mazda MX5 NA 1.8 Turbo BorgWarner EFR 6258, MS3Pro :P :P :P
Coming soon: ITB, WLLK (Laminova), water injection

Benutzeravatar
Luheuser
Beiträge: 920
Alter: 38
Registriert: Mo Apr 20, 2009 3:53 pm
Wohnort: Wiesbaden/München

Re: Ladedruckregelung schwingt

#28 Beitragvon Luheuser » Do Apr 12, 2018 5:58 am

Tach, ist du hier weiter gekommen?
Golf 2 4 Motion 2,0l 16v Turbo


Run with:
MS3 oelprinz
Vollsequentiell, 4fach AGT über CAN,

TS:v2.5.05


Zurück zu „Tuning“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste