www.MegaSquirt.de

Das deutschsprachige MegaSquirt-Forum

Firmware auf UMC 1 aufspielen

Nachricht
Autor
Maisi
Beiträge: 4
Registriert: Do Jun 07, 2012 1:22 pm

Firmware auf UMC 1 aufspielen

#1 Beitragvon Maisi » So Apr 01, 2018 11:25 pm

Guten Abend,

Hab heute Nachmittag meine UMC 1 fertig gelötet, ich hab nun das Problem das immer ein
Fehler kommt beim aufspielen der Firmware, hab noch eine am laufen und ich meine das es damals
beim ersten mal auch etwas schwieriger war als später bei updaten.
Ich hab es mal mit lötbrücke beim bootpin versuch und mal ohne macht kein Unterschied bricht
immer gleich ab und ich komm im Moment nicht weiter.

evtl. hat ja einer von euch eine Idee? oder stell mich nur zu blöd an ;)

12V Versorgung ist da ,verbaut ich der org. UMC USB Wandler CH 341 Com Port passt und
so wie ich das sehe wird sie auch erkannt nur lässt sich die Firmeware nicht auf die Umc schreiben.

Danke schon mal

MFG.

Debug message Level:
1: Normal
2: More detail
3: + serial comms
4: + the s19 file as parsed
Selection (default: 1): 1

Do you want to scan your serial ports automatically? (y/n default y)

Trying: COM1 ..Waiting...
Waiting...
Waiting...
Waiting...
Trying: COM4 ..Waiting...
Waiting...
COM4 Fetching chip version.
MS2/Microsquirt/GPIO hardware found.
MS2/Microsquirt-type ECU detected
Boot-jump/monitor mode detected

Do you want to use COM4 (y/n default = y)

Found firmware files on disk : microsquirt.s19 : microsquirt-module.s19 : mspnp2.s19 : megasquirt2.s19


1: Megasquirt 2.
2: Microsquirt (cased.)
3: Microsquirt module (includes DIYPNP).
4: MSPNP2.


File to upload (1, 2, filename, default= megasquirt2.s19): 1

========================================================
Settings selected:
Serial port: COM4
S19 File: megasquirt2.s19
Debug level: 1
Jumperless reflash disabled
Not preserving sensors calibrations
========================================================
Press enter to continue...
Loading boot-strap monitor
Attempting Wakeup...
Erasing main flash!
Erased.
Sending firmware to controller...
Error code 0x0 ] 0.4%


Got an error code! Reflashing failed - please try again.

Press enter to continue...

azmartin
Beiträge: 202
Alter: 39
Registriert: Mi Sep 17, 2014 11:50 am
Wohnort: 64342 Seeheim-Jugenheim

Re: Firmware auf UMC 1 aufspielen

#2 Beitragvon azmartin » Mo Apr 02, 2018 12:19 am

Hallo,

lässt Du das Tool als Admin laufen? Ich glaube da gabs mal was. Ansonsten setze mal den Debuglevel hoch vielleicht springt dann mehr dazu raus wo es hängt.

Gruß und viel Erfolg

Martin
Erprobungsfahrzeug: Polo 86c 1.3 ITB mit Honda SC57 Klappenteilen
Vertrieb, Beratung, Abstimmung von und mit MS2 / MS3 Steuergeräten

Maisi
Beiträge: 4
Registriert: Do Jun 07, 2012 1:22 pm

Re: Firmware auf UMC 1 aufspielen

#3 Beitragvon Maisi » Di Apr 03, 2018 9:07 pm

Jepp war als Admin aber es klappt nicht, hab jetzt auch na anderes USB Kabel Versucht und einen andern PC aber leider ohne Erfolg.

Hier mal noch wo es immer Hängen bleibt im Detail.

Hat jemand nee Idee vill. doch was falsch verlötet? hab aber allen X mal geprüft und nix Entdeckt....

TX: 0d
RX: 00 00 e0
Error code 0x00
Prompt was 0xe0
Attempting Wakeup...
TX: 0d
RX: 08 3e e1
Error code 0x08
Status code 0x3e
Prompt was 0xe1
Attempting Wakeup...
TX: 0d
Response to C_WAKE_UP looks misaligned, retrying
RX: e1 00 6c
Prompt was 0x6c
Attempting Wakeup...
TX: 0d
Response to C_WAKE_UP looks misaligned, retrying
RX: e1 00 6c
Prompt was 0x6c
Attempting Wakeup...
TX: 0d
Response to C_WAKE_UP looks misaligned, retrying
RX: e1 00 6c
Prompt was 0x6c
Attempting Wakeup...
TX: 0d
Response to C_WAKE_UP looks misaligned, retrying
RX: e1 00 6c
Prompt was 0x6c
Attempting Wakeup...
TX: 0d
Response to C_WAKE_UP looks misaligned, retrying
RX: e1 00 6c
Prompt was 0x6c
Attempting Wakeup...
TX: 0d
Response to C_WAKE_UP looks misaligned, retrying
RX: e1 00 6c
Prompt was 0x6c
Attempting Wakeup...
TX: 0d
Response to C_WAKE_UP looks misaligned, retrying
RX: e1 00 6c
Prompt was 0x6c
Attempting Wakeup...
TX: 0d
Response to C_WAKE_UP looks misaligned, retrying
RX: e1 00 6c
Prompt was 0x6c
Could not wake up processor, exiting...
Press enter to continue...

W201OnAir
Beiträge: 3
Registriert: Mi Nov 15, 2017 4:35 pm

Re: Firmware auf UMC 1 aufspielen

#4 Beitragvon W201OnAir » Mo Okt 29, 2018 10:14 pm



Zurück zu „Zusammenbau“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste

cron